Results 1 to 14 of 14
  1. #1

    PC struggling in BF1

    Hi all,

    My PC has some performance issues. Its really suffering when it comes to playing BF1, getting an fps of 30-50, could even go lower sometimes.
    Not just BF1, even some games, im getting very low fps too.
    Apparently when i crossfire both cards the performance gets worst in games but i get full performance when i use it in Unigine Valley for benchmarking. What does this mean?
    Anyways, all drivers are up to date, temperatures for CPU and GPU are normal.


    CPU: intel i5-4690
    Mobo: Maximus VII Hero (LGA1150)
    Ram: Vengeance® Pro Series — 8GB (2 x 4GB) DDR3 DRAM 2400MHz C11 Memory Kit (CMY8GX3M2A2400C11R)
    Main GPU: Sapphire AMD R9 290 Tri-X
    Secondary GPU: Asus R9 290
    PSU: Corsair HX 1050
    Storage: Samsung EVO SSD 250gb, 1TB WD blue, 3TB WD blue.
    CPU cooler: Corsair H100i (in case you guys are wondering)
    Last edited by Fat293; Apr 22nd, 17 at 04:08 PM.

  2. #2
    Ups~~~

  3. #3
    try running one single card
    Iphone User ! Android User !

  4. #4
    Quote Originally Posted by syahzwan View Post
    try running one single card
    Tried, somehow its slightly better but not getting at least 60fps. Its strange how running dual cards makes it worst.

  5. #5
    do a bios update ?
    Iphone User ! Android User !

  6. #6
    Quote Originally Posted by syahzwan View Post
    do a bios update ?
    Hmmmm will try. Update you afterwards. Thanks though!

  7. #7
    that's weird I had two 290's before and did not experience something like this, since you've tried running one card, which of the two performed better? the asus or sapphire?

    my guess is there might be an issue with the one that has lesser performance. anyway..

  8. #8
    Quote Originally Posted by syahzwan View Post
    do a bios update ?
    Did a bios update, somehow still the same

  9. #9
    Quote Originally Posted by malouwang View Post
    that's weird I had two 290's before and did not experience something like this, since you've tried running one card, which of the two performed better? the asus or sapphire?

    my guess is there might be an issue with the one that has lesser performance. anyway..
    Could it be the RAM and CPU? I ran a cpu and ram widget and to found out that both CPU and RAM reached above the 90% mark!!!(even when Xfire or dont Xfire.Oh ya, the Sapphire somehow performed better.

  10. #10
    Oh yeah, have not considered that before. The 4690 is a beast in gaming no doubt about that but yeah, cpu and ram usage reaching 90% is quite alarming, are you sure your pc is clean of viruses or malware?

    You might want to do a total disassembly of your whole system just in case, heck you might even want to try to reseat your cpu and ram.

  11. #11
    Quote Originally Posted by malouwang View Post
    Oh yeah, have not considered that before. The 4690 is a beast in gaming no doubt about that but yeah, cpu and ram usage reaching 90% is quite alarming, are you sure your pc is clean of viruses or malware?

    You might want to do a total disassembly of your whole system just in case, heck you might even want to try to reseat your cpu and ram.
    Yeah i heard so too. Just full pc scan, nope, no virus or malware.

    Already disassembled everything including the cpu and ram, put it back properly anndd yeah, still the same.

  12. #12
    upz~~~

  13. #13
    Registered User rEe_TaN's Avatar
    Join Date
    Dec 2005
    Location
    West Area
    Posts
    1,225
    1) Try running in low settings. What's the FPS for this? - Make sure u disable v-sync or shadows as that actually can kill fps a-lot.
    2) AMD driver - Did you try downgrade or upgrade?
    3) Tried other games, like MWO, WoWs or Armored Warfare to see if FPS drops like hell.
    4) If other games have this issue as 3) most likely is hardware issue.
    My Game Rig~ :
    Processor: FX8350
    Mobo: Asus Crosshair V Formula
    Memory: 12GB Transcend DDR3 2000mhz @ 9/9/9/24, 1600mhz
    Audio: Creative Sound Blaster X-Fi Titanium HD
    Storage: OCZ Vertex 128GB & Toshiba 2TB HDD
    Graphic: Sapphire 7970 3GB
    PSU: Seasonic X760w
    Optical Drive: LG RW-DVD Rom
    Casing: CM Cosmos 2 Ultra Tower
    Monitor: Dell U2311H IPS
    Cooling: XSPC EX360 Rad & MCP655 Pump w/ Bitspower Fittings


    A World of Endless Love.. Thanks to Delun (Photographer) & Rachel (Model)

  14. #14
    Quote Originally Posted by rEe_TaN View Post
    1) Try running in low settings. What's the FPS for this? - Make sure u disable v-sync or shadows as that actually can kill fps a-lot.
    2) AMD driver - Did you try downgrade or upgrade?
    3) Tried other games, like MWO, WoWs or Armored Warfare to see if FPS drops like hell.
    4) If other games have this issue as 3) most likely is hardware issue.
    Hi there,
    my remakrs in bold letterings.
    1) Try running in low settings. What's the FPS for this? - Make sure u disable v-sync or shadows as that actually can kill fps a-lot.
    Playing at low settings does help but still, im getting fps like 30-60 sometimes, not very constant.
    BF3 & 4 and some other games, no issues in ultra settings but in Playerunknowns' Battleground, it was worst whem i played at high.
    But now its slightly better in low. FPS: 30-50 with lesser stuttering.


    2) AMD driver - Did you try downgrade or upgrade?
    Yes, i did, no difference.

    3) Tried other games, like MWO, WoWs or Armored Warfare to see if FPS drops like hell.
    Tried amoured warfare, war thunder, world of tanks and etc., not much issues

Similar Threads

  1. Are US banks struggling?
    By VRNews in forum Singapore Properties Newsroom
    Replies: 0
    Last Post: Dec 1st, 12, 02:09 PM
  2. Are US banks struggling?
    By VRNews in forum Singapore Properties Newsroom
    Replies: 0
    Last Post: Oct 22nd, 12, 01:37 PM
  3. China developers seen struggling
    By VRNews in forum Singapore Properties Newsroom
    Replies: 0
    Last Post: Oct 4th, 11, 07:52 AM
  4. India struggling at 142/4 at lunch
    By VRNews in forum Singapore Automobile News
    Replies: 0
    Last Post: Jul 25th, 11, 08:54 PM
  5. AMD Invests $7.5M in struggling Transmeta
    By bigsale in forum News around the web!
    Replies: 6
    Last Post: Jul 8th, 07, 01:53 AM

Tags for this Thread